You May Be Unable To Open The Workflow Designer After Installing Laserfiche Scanning 8.1 or Laserfiche WebLink 8.0.

August 8, 2014 | KB: 1012242
Laserfiche 8.1, WebLink 8.0, Workflow Suite 8

Summary

When you attempt to open the Workflow Designer, you may receive the following error message:

    Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.

    Object reference not set to an instance of an object.

Cause

This error can occur if you install Laserfiche Scanning 8.1 or WebLink 8.0 on the same computer as the Workflow Designer. There is a file version conflict with a file located in the Windows Global Assembly Cache (GAC). Laserfiche Scanning 8.1 and WebLink 8.0 install a newer version of a .dll file that is incompatible with the Workflow Designer.

Resolution

There are updated versions of the Laserfiche 8.1 and WebLink 8.0 installation packages available on the Laserfiche Support Site. Due to the nature of the GAC, you must first uninstall all the affected programs (Workflow, WebLink, and Client with Scanning) before reinstalling. This includes all Workflow components if you have more than just the Workflow Designer installed on the computer.

After uninstalling all affected products, restart the computer. Then check the Global Assembly Cache (C:\Windows\assembly) for Laserfiche.Base (version 1.0.0.0). If the file still exists after you've already uninstalled the affected products, please delete that .dll file. If you needed to manually delete that file, restart the computer again. Then reinstall the affected programs.

If you downloaded Laserfiche 8.1 after June 3, 2009 and Weblink 8.0 after June 5, 2009, you have the updated installation packages.