A "Could not connect to the server. (797)" Error Occurs When Connecting to Laserfiche With Windows Authentication.

May 11, 2009 | KB: 1012211
Laserfiche Server - Team (MSDE) 8, Laserfiche Server - United (MS SQL) 8, Laserfiche Server - United (Oracle) 8, Laserfiche 9

Summary

When attempting to log in to Laserfiche using Windows authentication, you may receive the following error message:

    Could not connect to the server. (797)

Cause

You may encounter this issue with very large domains that contain many groups. In a large domain, the login request can create an HTTP header that exceeds the default size limit.

Resolution

Modify the registry to increase the header length limit.

To modify header length limits

  1. On the computer hosting Laserfiche Server 8, click Start and then click Run.
  2. Type the following and click OK to open the Windows Registry Editor:

    regedit

  3. Browse to the following key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters

  4. From the Edit menu, point to New and click DWORD Value.
  5. Name the new value:

    MaxFieldLength

  6. Double-click MaxFieldLength and set the Base option to decimal.
  7. Set the value to:

    32768

  8. From the Edit menu, point to New and click DWORD Value.
  9. Name the new value:

    MaxRequestBytes

  10. Double-click MaxRequestBytes and set the Base option to decimal.
  11. Set the value to:

    32768

  12. Stop the Laserfiche Server service.
  13. Click Start and then click Run.
  14. Type the following and click OK to open a command prompt:

    cmd

  15. Type the following and press ENTER to stop the HTTP service:

    net stop http

  16. Type the following and press ENTER to start the HTTP service:

    net start http

  17. Restart the Laserfiche Server service.

Related Links

See the following Microsoft Knowledge Base article for more information on the "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters" registry key.

http://support.microsoft.com/kb/820129