A "No response received from the server. [780]" Error Occurs When Connecting To Your Laserfiche Repository.

March 30, 2009 | KB: 1012184
Laserfiche 8, Laserfiche 9

Summary

When you attempt to connect to your Laserfiche repository, the Laserfiche Client may display the following error message:

    No response received from the server. [780]

Cause

This error can occur if your client program is unable to communicate with the Laserfiche Server. There are a many possible causes of communication failure:

  • The Laserfiche Server service may not be running. See Workaround 1.
  • This error can occur if the Laserfiche Server is unable to connect to your domain's DNS server. See Workaround 2.
  • One possible cause may be if a firewall is blocking communication on the Laserfiche Server listening port. Another cause may be if an anti-virus solution is blocking Laserfiche. See Workaround 3.

Workaround 1

Start the Laserfiche Server service.

Workaround 2

Edit the registry to prevent the Laserfiche Server from attempting to do a reverse name lookup.

Important: Disabling reverse name lookup for the Laserfiche Server affects the display of hostnames in the audit logs. Without reverse name lookup, hostnames will display a computer's IP address, instead of the computer's name.

Important: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs.

To disable reverse name lookup for the Laserfiche Server

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and click OK to load the Windows Registry Editor:

    regedit

  3. Expand HKEY_LOCAL_MACHINE.
  4. Expand SOFTWARE.
  5. Expand Laserfiche.
  6. Expand Engine.
  7. Expand 8.0.
  8. Select the HttpServ key.
  9. From the Edit menu, point to New and click DWORD Value.
  10. Name the new value:

    ReverseNameLookup

  11. Double-click the ReverseNameLookup value you created in the previous step.
  12. Set the value to 0.
  13. Restart the Laserfiche Server.

Workaround 3

Configure your firewall for Laserfiche 8. By default, the Laserfiche Client and Server communicate over ports 80 or 5050, and port 5051. Make sure that these ports are open on all firewalls between the Laserfiche Client and the Laserfiche Server.

Make sure that any anti-virus software recognizes Laserfiche. If necessary, configure your anti-virus software with an exception for Laserfiche.

Related Links

1012084 Configuring Your Firewall for Laserfiche 8.