A "TextProvider.exe - Application Error" Error Occurs When Indexing.

March 9, 2009 | KB: 1012174
Laserfiche Server - Team (MSDE) 8, Laserfiche Server - United (MS SQL) 8, Laserfiche Server - United (Oracle) 8

Summary

When indexing your repository, you may receive an error message similar to the following error message when the Search Engine attempts to use certain IFilters:

    The instruction at "0x0700609c" referenced memory at "0x00000014". The memory could not be "read".

    Click on OK to terminate the program

Cause

TextProvider.exe relies on the Microsoft Visual C++ runtime libraries for certain memory management operations. In certain situations, there are issues with the automated process. TextProvider now manually handles those cases.

Resolution 1

This issue is resolved in Laserfiche 8.1 and later. Please upgrade to the latest version of Laserfiche.

Resolution 2

There is a hotfix available for Laserfiche 8.0.2. The fix is an updated version of TextProvider.exe (version 8.0.2.839).

To update Laserfiche 8.0.2

  1. Stop the Laserfiche Full-Text Indexing and Search Service.
  2. Click the following link to download a zip file containing the updated version of TextProvider.exe.

    Hotfix_SCR43918.zip

  3. Replace your existing version of TextProvider.exe with the updated version included in the zip file. TextProvider.exe is located in your Laserfiche Server installation folder. By default, the Laserfiche Server is installed at "C:\Program Files\Laserfiche\Server."
  4. Start the Laserfiche Full-Text Indexing and Search Service.
  5. Reindex your repository.