The Laserfiche Search Engine May Become Unstable When Indexing with Large Search Catalogs.

March 9, 2009 | KB: 1012173
Laserfiche Server - Team (MSDE) 8, Laserfiche Server - United (MS SQL) 8, Laserfiche Server - United (Oracle) 8

Summary

During the indexing process, the Laserfiche Search Engine can become unstable when optimizing large search catalogs.

Cause

The Laserfiche Search Engine performs internal optimizations when dealing with a large lflink.idx file. In certain situations, the optimization may not correctly modify the lflink.idx file, resulting in instability the next time the search engine needs to perform the optimization process.

Resolution 1

This issue is resolved in Laserfiche 8.1 and later. Please upgrade to the latest version of Laserfiche.

Resolution 2

There is a hotfix available for Laserfiche 8.0.2. The fix includes updated versions of LFFTS.exe (version 8.0.2.840) and QRcmd.exe (version 8.0.2.840).

To update the Laserfiche 8.0.2 Search Engine

  1. Stop the Laserfiche Full-Text Indexing and Search Service.
  2. Click one of the following links to download a zip file containing updated versions of LFFTS.exe and QRcmd.exe.

    Hotfix_SCR43422_x86.zip

    Hotfix_SCR43422_x64.zip

  3. Replace your existing versions of LFFTS.exe and QRcmd.exe in your Laserfiche Server installation folder with the updated versions included in the zip file. By default, the Laserfiche Server is installed at "C:\Program Files\Laserfiche\Server."
  4. Start the Laserfiche Full-Text Indexing and Search Service.
  5. Use the Laserfiche 8 Administration Console to delete your repository's existing search catalog. Make sure that the SEARCH8 folder is empty.
  6. Use the Laserfiche 8 Administration Console to create a new search catalog for your repository.
  7. Reindex your repository.