Scanning Does Not Work on a Specific Day Each Year.

August 7, 2014 | KB: 1012166
Laserfiche 8.0.2, Scanning 8.0.2

Summary

On a certain day each year, Laserfiche Scanning will stop displaying captured images in the Scanning window and will be unable to send them to the repository (captured images will be stored under C:\Documents and Settings\username\Local Settings\Temp\Laserfiche Scanning). This issue applies to all scan stations, regardless of scan engine and scanner. The following known dates will be affected:

  • February 24, 2009
  • February 13, 2010
  • February 3, 2011
  • January 23, 2012
  • January 11, 2013

Note: Dates after 2013 may also be affected.

The issue lasts for 24-hours. After the date has passed, the issue will resolve itself for roughly one year.

Cause

This issue is caused by an internal error involving converting dates into Hijri date format. This conversion process did not correctly handle February in non-leap years.

Resolution

There is a hotfix available for Laserfiche Scanning 8.0.2. The fix is an updated version of Scanning.Base.dll (version 8.0.2.800). It must be applied to all scanning machines. You may use a logon script to automate this process.

To update Laserfiche Scanning 8.0.2

  1. Click the following link to download the hotfix.
  2. Hotfix_SCR45032.zip

  3. Close Laserfiche Scanning and the Laserfiche Client.
  4. Copy the updated version of Scanning.Base.dll to the install path for Laserfiche Scanning. By default this location is C:\Program Files\Laserfiche\Client 8\Scanning. When asked by Windows to confirm your decision to overwrite the existing version of this file, click Yes.