An "Exception from HRESULT: 0x80040BC4 [3012]" Error Occurs When Opening Documents in Web Access.

February 9, 2009 | KB: 1012150
Web Access 8

Summary

When you open a document through Web Access, you may receive the following error message:

    Exception from HRESULT: 0x80040BC4 [3012].

Cause

The user account used to authenticate to IIS may not have sufficient Windows permissions to the "cacheDirectory" folder and the "tempDirectory" folder. These two folders are located in the Web Access installation folder. By default, they are located at "C:\Program Files\Laserfiche\Web Access 8\cacheDirectory" and "C:\Program Files\Laserfiche\Web Access 8\tempDirectory."

Resolution

If the Web Access 8 virtual directory is configured for anonymous access, make sure that the specified Windows user account can read and write to the "tempDirectory" and "cacheDirectory" folders. If the virtual directory is configured for Windows authentication, make sure that all necessary Windows user accounts can access the folders.