A "Creating a search catalog failed. (9236)." Error Occurs When Creating a New Search Catalog.

January 9, 2014 | KB: 1012139
Laserfiche Server - Team (MSDE) 8, Laserfiche Server - United (MS SQL) 8, Laserfiche Server - United (Oracle) 8, Laserfiche 9

Summary

When attempting to create a new search catalog through the Laserfiche 8 Administration Console, you may receive the following error message:

    Creating a search catalog failed. (9236)

Cause

There may be pre-existing data from a previous search catalog.

Workaround

Manually delete the existing registry key at HKEY_LOCAL_MACHINE\SOFTWARE\Laserfiche\LFFTS\DataBase\YourRepositoryName. You may also need to delete the existing search catalog files.

To manually delete search catalog data

  1. Stop both the Laserfiche Full-Text Indexing and Search service and the Laserfiche Server service.
  2. Open the Windows Registry Editor.
    1. Click Start and click Run.
    2. Type the following and then click OK

      regedit

  3. Expand HKEY_LOCAL_MACHINE.
  4. Expand SOFTWARE.
  5. Expand Laserfiche.
  6. Expand LFFTS.
  7. Expand DataBase.
  8. Select the key with your repository's name.
    • In Laserfiche 8, the key name will match your repository's name.
    • In Laserfiche 9, the key names are hash values. The catalog you want will the one where the Name string value matches your repository's name.
  9. From the Edit menu, click Delete.
  10. Using Windows Explorer, browse to the location of your repository and delete the existing Search8 folder (for Laserfiche 8) or Search folder (for Laserfiche 9).
  11. Restart the Laserfiche Server service and the Laserfiche Full-Text Indexing and Search service.
  12. Retry creating a new search catalog from the Laserfiche Administration Console.