A "You have tried to create a channel to a service that does not support .NET Framing." Error Occurs When Loading the Rules Manager in the Workflow Designer.

December 15, 2008 | KB: 1012124
Workflow Suite 8

Summary

When loading the rules manager in the Workflow Designer, you may receive the following error message:

    You have tried to create a channel to a service that does not support .Net Framing. It is possible that you are encountering an HTTP endpoint.

Cause

There may be a port conflict on port 8082.

Resolution

Manually edit the "Laserfiche.Workflow.Service.exe.config" and "Laserfiche.Workflow.Designer.exe.config" files to configure Workflow to use a different port. Modify the "Laserfiche.Workflow.Service.exe.config" file on the computer hosting the Workflow Server. You must edit the "Laserfiche.Workflow.Designer.exe.config" file on each computer with a Workflow Designer installation.

To change the port for Workflow Suite 8

  1. On the computer hosting the Laserfiche Workflow Server, open the "Laserfiche.Workflow.Service.exe.config" file using a text editor. By default, the file is located at "C:\Program Files\Laserfiche\Laserfiche Workflow." Perform a search for "8082" and replace all instances with a new port value.
  2. Save your changes.
  3. On the computer with the Laserfiche Workflow Designer, open the "Laserfiche.Workflow.Designer.exe.config" file using a text editor. By default, the file is located at "C:\Program Files\Laserfiche\Laserfiche Workflow." Perform a search for "8082" and replace all instances with the port value you specified in the "Laserfiche.Workflow.Service.exe.config" file.
  4. Save your changes.
  5. Restart your Workflow Server and Subscriber services.

More Information

Laserfiche Workflow Suite 8.0 uses the following default ports: 8081-8084 and 8086.

Related Links

1011961 The Laserfiche Workflow Server Service May Not Start If SharePoint Central Administration Is Installed On The Same Computer.