A "Trustee not found. [9012]" Error Occurs When Adding An Entry In the Entry Access Dialog Box.

February 2, 2009 | KB: 1012122
Laserfiche 8

Summary

When adding a new set of entry access rights, you may receive the following error message:

    The trustee could not be found.
    Trustee not found. [9012]

Cause

The repository contains a trustee with a name that contains a slash character.

Steps to reproduce the issue:

  1. Create a trustee with a slash ('/') in the name.
  2. Using the Laserfiche Client, open up the Entry Access dialog for an entry.
  3. Click Add and select the trustee created in step 1.
  4. Click OK to save your changes and close the Entry Access dialog box.
  5. Reopen the Entry Access dialog box for that entry. The trustee added in step 3 does not appear in the list and attempting to make any changes results in the above error message.

Workaround

Rename the appropriate trustee so that the name does not contain the slash (/) character.