An "Error 14001: This application has failed to start because the application configuration is incorrect." Error Occurs When Starting the Laserfiche Server.

October 13, 2008 | KB: 1012088
Laserfiche Server - Team (MSDE) 8, Laserfiche Server - United (MS SQL) 8, Laserfiche Server - United (Oracle) 8, Laserfiche 9

Summary

After reinstalling the Laserfiche Server, you may receive the following error message when starting the Laserfiche Server:

    Could not start the Laserfiche Server 8.0 service on Local Computer.

    Error 14001: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.

In addition, the Event Viewer may contain system error messages involving SideBySide.

Cause

This error may occur if the uninstall process could not remove an existing version of a Laserfiche side-by-side assembly. The assembly is then not correctly updated during the reinstallation process.

Resolution

Manually delete the affected assemblies and manifests in your "C:\WINDOWS\WinSxS" folder and C:\WINDOWS\WinSxS\Manifests" folder, rerun the installation, and select the repair option.

Browse to "C:\WINDOWS\WinSxS" and delete files and folders with names that begin with the following prefixes. Repeat the process with the similarly named files in "C:\WINDOWS\WinSxS\Manifests."

  • x86_zlib1_
  • x86_xmlsec_
  • x86_libxslt_
  • x86_libxml2_
  • x86_icuin36_
  • x86_icuuc36_
  • x86_icudt36_

If you are using the 64-bit version of Laserfiche Server, you should also delete folders with names that begin with the following prefixes:

  • amd64_zlib1_
  • amd64_xmlsec_
  • amd64_libxslt_
  • amd64_libxml2_
  • amd64_icuin36_
  • amd64_icuuc36_
  • amd64_icudt36_