A "HRESULT: 0x80040BC2 [3010]" Error Occurs When Viewing Documents.

August 18, 2008 | KB: 1012037
Web Access 8

Summary

When you open a document in Web Access 8.0.0, you may receive the following error message:

    Exception from HRESULT: 0x80040BC2 [3010].

Cause

This error may occur if you have configured anonymous access to use the Windows IUSR account and your repository is configured for watermarks. This error occurs when the IUSR Windows account does not have sufficient rights to the following folder:

    C:\Documents and Settings\MachineName\ASPNET\Local Settings\Temp

The watermark mechanism included with Web Access 8.0.0 uses this temporary folder.

Resolution

This issue is resolved in Web Access 8.0.1. The mechanism now defaults to using the Web Access 8 installation folder's "tempDirectory" folder. Please upgrade to the latest version of Laserfiche Web Access.

Workaround for Web Access 8.0.0

Grant the IUSR account rights to "C:\Documents and Settings\MachineName\ASPNET\Local Settings\Temp."