An "AddressAlreadyInUse" Socket Error Occurs When The Workflow Server And The Laserfiche Server Are Installed On The Same Computer.

August 4, 2008 | KB: 1012030
Workflow Suite 8, Laserfiche Server - Team (MSDE) 8, Laserfiche Server - United (MS SQL) 8, Laserfiche Server - United (Oracle) 8, Laserfiche 9

Summary

When Laserfiche Workflow Server 8 and Laserfiche Server 8 are installed on the same computer, Workflow may log the following error message to the workflow error.log file:

    Type : System.Net.Sockets.SocketException, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : Only one usage of each socket address (protocol/network address/port) is normally permitted
    Source : System
    Help link :
    ErrorCode : 10048
    SocketErrorCode : AddressAlreadyInUse
    NativeErrorCode : 10048
    Data : System.Collections.ListDictionaryInternal
    TargetSite : Void DoBind(System.Net.EndPoint, System.Net.SocketAddress)
    Stack Trace : at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.Sockets.Socket.Bind(EndPoint localEP) at Laserfiche.Project.LicenseSerialBroadcaster.BroadcastingThread(Object state)

Cause

The Workflow Server and the Laserfiche Server contain mechanisms that check for duplicate serial numbers. The mechanisms use the same port. This error message can be safely ignored as it will not impact the functionality of either the Workflow Server or the Laserfiche Server.