WebLink May Cause Excessive Memory Usage in the Laserfiche Server When You Perform Multiple Searches During One Login Session.

September 21, 2009 | KB: 1012007
WebLink 7

Summary

When you perform multiple searches from WebLink, memory usage for the Laserfiche Server increases after each search. Eventually, you may receive "out of memory" error messages.

Cause

WebLink opens a new search handle for each new search without clearing the previous search handle.

Resolution

There is a hotfix available for WebLink 7.0.5. The fix includes updated versions of the following files:

  • AssemblyInfo.vb
  • Browse.aspx
  • DocView.aspx
  • ExpirationWarning.inc
  • Login.aspx
  • MyWebLink.aspx
  • MyWebLink.aspx.vb
  • Search.aspx
  • Search.aspx.vb
  • WebLink7.dll
  • WebLink7.vbproj
  • WebLinkControls.dll
  • WebLinkStyles.css

To update WebLink 7.0.5

  1. Click the following link to download a zip file containing the hotfix files.

    Hotfix_SCR36787.zip

  2. Replace the AssemblyInfo.vb, Browse.aspx, DocView.aspx, ExpirationWarning.inc, Login.aspx, MyWebLink.aspx, MyWebLink.aspx.vb, Search.aspx, Search.aspx.vb, WebLink7.vbproj, and WebLinkStyles.css files in "C:\Program Files\Laserfiche\WebLink 7\Web Files" with the ones included in the zip file.
  3. Replace the WebLink7.dll and WebLink Controls.dll files in "C:\Program Files\Laserfiche\WebLink 7\Web Files\bin" with the ones included in the zip file.
  4. Restart the World Wide Web Publishing service.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Scroll down and select World Wide Web Publishing.
    5. From the Action menu, select All Tasks, and click Restart.

Related Links

Please see the following Laserfiche Knowledge Base article for information regarding a similar issue in Laserfiche Web Access 7:

1012006 Web Access May Cause Excessive Memory Usage in the Laserfiche Server When You Perform Multiple Searches During One Login Session.