Summary
A running workflow may pause on an activity for five minutes.
Cause
In certain situations, the Workflow Subscriber may incorrectly flag an internal performance optimization as having failed. This type of error causes the Subscriber to wait five minutes before reprocessing the request.
Resolution
This issue is now less frequent in Workflow 8.0.1. Please update to the latest version of Laserfiche Workflow. If you still encounter this issue with the latest version of Laserfiche Workflow 8.0.1, please see the following workaround.
Workaround
Edit the Workflow Subscriber configuration file to disable the compact notifications performance optimization.
Warning: Make a copy of your configuration file before making any changes. In the event the Subscriber will not run after completing the steps below, replace the modified configuration file with the original file.
To disable the compact notifications option
<subscriberConfig></subscriberConfig>
<subscriberConfig logRuleEvents="true" logConditionEvents="true" />
<subscriberConfig compactChangeNotifications = "false" />