A Running Workflow Pauses for Five Minutes.

June 30, 2008 | KB: 1012002
Workflow Suite 8

Summary

A running workflow may pause on an activity for five minutes.

Cause

In certain situations, the Workflow Subscriber may incorrectly flag an internal performance optimization as having failed. This type of error causes the Subscriber to wait five minutes before reprocessing the request.

Resolution

This issue is now less frequent in Workflow 8.0.1. Please update to the latest version of Laserfiche Workflow. If you still encounter this issue with the latest version of Laserfiche Workflow 8.0.1, please see the following workaround.

Workaround

Edit the Workflow Subscriber configuration file to disable the compact notifications performance optimization.

Warning: Make a copy of your configuration file before making any changes. In the event the Subscriber will not run after completing the steps below, replace the modified configuration file with the original file.

To disable the compact notifications option

  1. Stop the Laserfiche Workflow Subscriber service.
    1. Open Windows Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Right-click the Laserfiche Workflow Subscriber service and select Stop.
  2. Using a text editor (e.g. Notepad), open the Subscriber configuration file: Laserfiche.Workflow.Subscriber.exe.config. This file is located in the Workflow 8 installation folder. By default, this folder is located at "C:\Program Files\Laserfiche\Laserfiche Workflow."
  3. Look for the subscriberConfig element.
    • The element will look similar to the following sample if logging is off for the Workflow Subscriber:

      <subscriberConfig></subscriberConfig>

    • The element will look similar to the following sample if logging is on for the Workflow Subscriber:

      <subscriberConfig logRuleEvents="true" logConditionEvents="true" />

  4. Add the compactChangeNotifications attribute and set it to false.
  5. The subscriberConfig element should end up looking similar to the following sample:

    <subscriberConfig compactChangeNotifications = "false" />

  6. Save your changes file and restart the Workflow Subscriber service.
    1. Open Windows Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Right-click the Laserfiche Workflow Subscriber service and select Start.