A "Failed to load image. File input/output error. [9004]" Error Occurs When Opening a Document.

July 14, 2011 | KB: 1011997
Laserfiche 8, Laserfiche 9

Summary

When viewing a document, you may receive the following error message:

    Failed to load image. File input/output error.[9004]

Cause

Laserfiche is unable to access volume information. See the following possible causes:

  • The volume paths set for your repository do not match up with the actual volume locations.
  • The Laserfiche Server service may be running as a Windows user account that does not have rights to the volume location.

Resolution 1

Use the Laserfiche Administration Console to verify that the volume paths for your repository are correct.

To modify volume paths:

  1. Load the Laserfiche 8 Administration Console.
  2. Expand the appropriate Laserfiche Server item and log into the desired Laserfiche repository.
  3. Select the Volumes item.
  4. Verify that the values under the Fixed Path and Removable Path columns are valid paths and that the volume files reside in the specified paths.

Resolution 2

Verify that the Laserfiche Server service account has rights to the repository's volume paths.

For example, if a volume is located on a different computer from the one hosting the Laserfiche Server, make sure that the Laserfiche Server service is not running as Local System. Modify the service to log on as a valid domain account that can access the specified volume location.