A "The search engine is offline. [9131]" Error Occurs When Performing a Text Search.

May 5, 2008 | KB: 1011975
Laserfiche Server - Team (MSDE) 8, Laserfiche Server - United (MS SQL) 8, Laserfiche Server - United (Oracle) 8, Laserfiche 9

Summary

When you attempt to perform a text search, you may receive the following error message:

    The search engine is offline. [9131]

The Laserfiche Full-Text Indexing and Search service (LFFTS.exe) may not be running.

Cause

This error may occur after you restart the computer hosting Laserfiche Server. The Laserfiche Search Service has a dependency on the Laserfiche Server service. However, during the computer startup process, if the Laserfiche Server takes some time to finish loading, the Windows Service Control Manager may report that the Laserfiche Server has failed to start. This prevents the Laserfiche Search Service from automatically starting.

Workaround 1

Add a registry value to start the Laserfiche Search Service.

  1. Under the "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run" registry key, add the following string value:

    StartLFFTS

  2. Set the string value to:

    C:\WINDOWS\System32\net.exe start LfFTSrv

Workaround 2

Manually start the Laserfiche Full-Text Indexing and Search service.

To start the Laserfiche Full-Text Indexing and Search service

  1. Load the Windows Services MMC snap-in.
    1. Click Start and click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
  2. Scroll down and select Laserfiche Full-Text Indexing and Search Service.
  3. From the Action menu, click Start.