Summary
The Laserfiche Search Service may become locked out of a repository if you unregister and reregister the repository to a different location.
After the initial move, you may see application errors in the Windows Event Viewer similar to the following:
Failed to find the search catalog 'YourRepository'. Please check the input name to see if the catalog is available. Contact technical support or your authorized reseller for further assistance if needed.
The above error may repeat for some time and then become replaced with the following error:
Unload search catalog 'YourRepository' because the Laserfiche full text search service could not connect to the corresponding repository. Server error message: Account locked.
Cause
The Laserfiche Search Service maintains its own reference to the location of your Laserfiche 8 repository's search index files in the Search8 folder. If you change the location of your repository, the search service may not correctly update itself to look in the new location. The search service will continue to try to connect to the repository using the old path location. Repeated connection failures may cause the Laserfiche Server to flag the search service's Laserfiche user account as a bad account and lock out the Laserfiche Search Service.
One way to check for this situation is to load the Laserfiche 8 Administration Console and log in to your repository. View the Sessions and check for any connections using the FTSUSER$ user account. If there are no sessions using that user account and the Laserfiche Search Service is currently running, you may be affected by this issue.
Workaround
The following VBScript file performs the following actions:
After you successfully run the following VBScipt, you must reindex your repository.
Important: The following VBScript makes modifications to your SQL database. Please make sure you have a valid backup of the database before running the script.
Click the following link to download a zip file containing the VBScript file.