A "The maximum number of sessions has been reached. [9030]" Error Occurs When You are the Only User Logging in to a Repository.

April 21, 2008 | KB: 1011968
Laserfiche Server - Team (MSDE) 8, Laserfiche Server - United (MS SQL) 8, Laserfiche Server - United (Oracle) 8, Laserfiche 9

Summary

When you attempt to log in to a repository, you may receive the following error message even though there are no other connections to the Laserfiche Server:

    The maximum number of sessions has been reached. [9030]

The Windows Event Viewer will contain the following application warning:

    No valid product license could be found in the license file for Laserfiche. Ensure that the license is not expired, any applicable dongle is correctly installed, and that the system's host ID matches the one in the license. If problems persist, please contact your authorized reseller. One read-only connection to one repository will be allowed.

Cause

The Laserfiche Server license file is invalid or the dongle is not correctly installed. When the Laserfiche Server encounters a licensing issue, it starts up in "read-only" mode, allowing only 1 read-only connection. If you then attempt to log in to a repository using a user account that is not configured as a read-only account, you will receive the maximum sessions reached error.

Resolution

Verify that there is a valid license file in your Laserfiche Server installation folder. If your Laserfiche Server requires a dongle, verify that the dongle drivers are installed and that the dongle is properly plugged in.