The Laserfiche Workflow Server Service May Not Start If SharePoint Central Administration Is Installed On The Same Computer.

April 14, 2008 | KB: 1011961
Workflow Suite 8

Summary

The Laserfiche Workflow Server service may not start if SharePoint Central Administration for Microsoft SharePoint Services is installed on the same computer.

Cause

Laserfiche Workflow Server and SharePoint Central Administration both use port 8081.

Resolution

Manually edit the "Laserfiche.Workflow.Service.exe.config" and "Laserfiche.Workflow.Designer.exe.config" files to configure Workflow to use a different port. You must edit the "Laserfiche.Workflow.Designer.exe.config" file on each computer with a Workflow Designer installation.

To change the port for Workflow Server

  1. On the computer hosting the Laserfiche Workflow Server, open the "Laserfiche.Workflow.Service.exe.config" file using a text editor. By default, the file is located at "C:\Program Files\Laserfiche\Laserfiche Workflow."
  2. Perform a search for "8081" and replace the value with a new port value.
  3. Save your change.
  4. On the computer with the Laserfiche Workflow Designer, open the "Laserfiche.Workflow.Designer.exe.config" file using a text editor. By default, the file is located at "C:\Program Files\Laserfiche\Laserfiche Workflow."
  5. Perform a search for "8081" and replace the value with the port value you specified in the "Laserfiche.Workflow.Service.exe.config" file.
  6. Save your change.

More Information

Laserfiche Workflow Suite 8.0 uses the following default ports: 8081-8084 and 8086.