Summary
When you close the Laserfiche Client, the LFSESSION.EXE process remains running. This may cause your Citrix session to hang or prevent your Citrix session from closing.
Cause
LFSESSION.EXE is a child process created by Laserfiche client applications to store repository authentication information. When you close the Laserfiche Client (LF.exe), it does not automatically end the LFSESSION.EXE process. This can cause your Citrix session to remain open in the background.
Workaround
Modify the following registry key to include special handling for LFSESSION.EXE:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI
Add or modify the following string value to include LFSESSION.EXE:
LogoffCheckSysModules
Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.
To modify the registry
regedt32
LogoffCheckSysModules
Related Links
Please see the following Citrix Knowledge Base article for additional information.