Your Citrix Session May Remain Open After Closing the Laserfiche Client.

March 3, 2008 | KB: 1011938
Laserfiche 7

Summary

When you close the Laserfiche Client, the LFSESSION.EXE process remains running. This may cause your Citrix session to hang or prevent your Citrix session from closing.

Cause

LFSESSION.EXE is a child process created by Laserfiche client applications to store repository authentication information. When you close the Laserfiche Client (LF.exe), it does not automatically end the LFSESSION.EXE process. This can cause your Citrix session to remain open in the background.

Workaround

Modify the following registry key to include special handling for LFSESSION.EXE:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI

Add or modify the following string value to include LFSESSION.EXE:

LogoffCheckSysModules

Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.

To modify the registry

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and then click OK to load the Windows Registry Editor:

    regedt32

  3. Expand HKEY_LOCAL_MACHINE.
  4. Expand SYSTEM.
  5. Expand CurrentControlSet.
  6. Expand Control.
  7. Expand Citrix.
  8. Expand wfshell.
  9. Expand TWI.
  10. Select the LogoffCheckSysModules string value. If the registry value does not exist, create the string value:
    1. From the Edit menu, point to New and click String Value.
    2. Name the value:

      LogoffCheckSysModules

  11. Double-click the registry value and add LFSESSION.EXE to the string value.

Related Links

Please see the following Citrix Knowledge Base article for additional information.

http://support.citrix.com/article/CTX891671