A "Permission denied. An administrator login is required" Error Occurs When Starting a Quick Fields Session.

February 18, 2008 | KB: 1011933
Quick Fields 7.1.2

Summary

When you load a Quick Fields session, you may receive the following error message:

    Permission denied. An administrator login is required

You start receiving this error message after applying the hotfix in Knowledge Base article 1011827 and configuring your session to automatically refresh all document class templates on session login.

Cause

The option to automatically refresh all document class templates requires the ability to modify the session configuration. If Quick Fields is not configured to start in administrator mode, you will receive this error message.

Resolution

Configure Quick Fields to always start in Administrator mode or disable the option to automatically refresh all document class templates on session login.

To always start in Administrator mode

  1. Load Laserfiche Quick Fields.
  2. From the Tools menu, click Options.
  3. On the Preferences tab, select the Display administrative features (Class Manager) at startup option.
  4. Click OK to save your changes.

To disable the option to automatically refresh document class template information

  1. Load Laserfiche Quick Fields.
  2. From the Tools menu, click Options.
  3. On the Preferences tab, clear the Refresh all document class templates on session login option.
  4. Click OK to save your changes.