Workflow May Not Route Correctly.

October 22, 2007 | KB: 1011895
Workflow Suite 7, Laserfiche Server - United (MS SQL)

Summary

In certain situations, Workflow may not correctly route documents and folders in your repository.

You may encounter one of the following symptoms:

  • Performance is slow and the Workflow events backlog continually grows.
  • Workflow may route entries to incorrect locations.
  • Workflow may not route any entries.

Cause

Certain optimizations in later versions of Laserfiche created incompatibilities between Workflow and the Laserfiche Server.

Resolution

There is a hotfix available for Workflow Suite 7.0.1 and Laserfiche Server 7.2.1. The fix includes a SQL script file and updated versions of EventDB.jar and WorkDistribution.jar.

Important: Please upgrade to the latest version of Laserfiche Server (7.2.1) and Laserfiche Workflow (7.0.1) before applying this hotfix.

To update Workflow Suite 7.0.1. and Laserfiche Server 7.2.1

  1. Click the following link to download a zip file containing the hotfix files.
    Hotfix_WorkflowSuite.zip
  2. Extract the contents to a temporary location.
  3. Run the wf.sql script on your Laserfiche SQL database.
    1. Click Start and then Run.
    2. In the Run dialog box, type the following and then click OK to run the script.

      osql -E -S SQLServerInstance -d "DatabaseName" -i "script.sql"

      SQLServerInstance is the name of your SQL Server instance name.

      DatabaseName is the name of the main SQL database associated with your Laserfiche repository.

      Script.sql is the full path (including the file name and extension) to the extracted wf.sql file.

  4. Stop the Laserfiche Server Automation service.
    1. Click Start and click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Scroll down and select Laserfiche Server Automation.
    5. From the Action menu, click Stop.
  5. Replace the EventDB.jar found in the ServerAutomation folder of the Workflow Suite installation folder with the EventDB.jar included in the zip file. By default, the file is located at "C:\Program Files\Laserfiche\WorkflowSuite\ServerAutomation."
  6. Replace the WorkDistribution.jar found in the agents folder of your Server Automation installation folder with the WorkDistribution.jar included in the zip file. By default, it is located at "C:\Program Files\Laserfiche\WorkflowSuite\ServerAutomation\Agents."
  7. Restart the Laserfiche Server Automation service.
    1. Click Start and click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Scroll down and select Laserfiche Server Automation.
    5. From the Action menu, click Start.