The Laserfiche Server May Crash in Specific Situations When it Detects an Invalid Index File.

August 7, 2014 | KB: 1011854
Laserfiche 7.2.1

Summary

The Laserfiche Server may become unstable in a specific situation involving an invalid .idx file.

Cause

This error can occur in certain situations when the Laserfiche Server detects an invalid .idx file. It will only occur if you previously applied one of the following hotfixes:

  • LFEng.dll (version 7.2.1.425)
  • LFEng.dll (version 7.2.1.430)
  • LFEng.dll (version 7.2.1.435)

Resolution

There is a hotfix available for the Laserfiche Server. The fix is an updated version of LFEng.dll (version 7.2.1.440).

Important: This hotfix includes changes made in two previous LFEng.dll hotfixes (7.2.1.410 and 7.2.1.425) that affect the external components of a Laserfiche repository. If you wish to directly update the release version of LFEng.dll (7.2.1.407) to LFEng.dll (7.2.1.440), you must also perform the necessary updates to your SQL database table structure, delete your repository's SEARCH folder, and re-index your repository. Knowledge Base article 1011782 details potential issues with applying this hotfix without updating your SQL database and reindexing.

To update the Laserfiche Server

  1. Click the following link to download a zip file containing the updated version of LFEng.dll.
    Hotfix_SCR31227.zip
  2. Stop the Laserfiche Server service.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Select Laserfiche Server 7.2.
    5. From the Action menu, point to All Tasks and select Stop.
  3. Replace your existing version of LFEng.dll located in your Laserfiche Server installation with the updated version contained in the zip file. By default, Laserfiche Server is installed at "C:\Program Files\Laserfiche\Server."
  4. Restart the Laserfiche Server service.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Select Laserfiche Server 7.2.
    5. From the Action menu, point to All Tasks and select Start.

Related Links

Please see the following Knowledge Base article for additional information on how the hotfixes included in LFEng.dll (version 7.2.1.410) and LFEng.dll (version 7.2.1.425) affect all subsequent LFEng.dll hotfixes.

1011782 Subsequent Laserfiche 7.2.1 LFEng.dll Hotfixes are Dependent on Changes made in Previous Laserfiche 7.2.1 LFEng.dll Hotfixes.