Web Access Scanning May Create Empty Documents When Scanning into a Folder Monitored by Laserfiche Workflow.

April 30, 2007 | KB: 1011804
Web Access 7.2.0, Web Access 7.2.1

Summary

When you use Web Access 7.2.x to scan into a folder that is monitored by Laserfiche Workflow, Web Access Scanning may silently fail to add the scanned pages into the document.

Cause

Laserfiche Server requires client applications to acquire document locks when they wish to modify documents. When Web Access Scanning scans a new document into Laserfiche, it first creates an empty document and assigns a template to the new document. It then releases its document lock and attempts to create a new lock when it begins adding scanned pages to the document. However, if Laserfiche Workflow is monitoring the folder you are scanning into, this short interval is enough time for Workflow to create its own lock on the object in order to evaluate workflow rules on the document. This prevents Web Access Scanning from being able to add the scanned pages to the document.

Resolution

There is a hotfix available for Laserfiche Web Access 7.2.1. The fix is an updated version of Scanning_CreateDocument.asp (last modified on March 29, 2007).

To update Web Access 7.2.1

  1. Click the following link to download a zip file containing the updated version of Scanning_CreateDocument.asp.
    Hotfix_SCR30390.zip
  2. Replace your existing version of Scanning_CreateDocument.asp located in the ASPs subfolder of your Web Access installation folder. By default, the file is located at "C:\Program Files\Laserfiche\Web Access\ASPs."