An "Error 1067: 'The process terminated unexpectedly" Error Occurs When Starting the Laserfiche Server Service.

April 23, 2007 | KB: 1011799
Laserfiche Server - Team (MSDE) 7, Laserfiche Server - United (MS SQL) 7, Laserfiche Server - United (Oracle) 7

Summary

When you attempt to start the Laserfiche Server service, you may receive the following error message:

    Error 1067: 'The process terminated unexpectedly'

Cause

There may be an invalid entry in the IndexQueue table.

Resolution

Manually clear out the IndexQueue SQL table.

To clear out the IndexQueue table using osql

  1. From the Start menu, select Run.
  2. Type the following and then click OK.

    cmd

  3. At the command prompt, type the following and then press ENTER:

    osql -E -S SQLInstance -d DatabaseName

    SQLInstance is the name assigned to the desired instance of SQL Server. This term should be replaced by the name of the computer hosting SQL Server. If you are using MSDE (i.e. Laserfiche Server (Team) or Standalone), then you should also append "\Laserfiche" (e.g. Computer\Laserfiche).

    DatabaseName is the name of the SQL database associated with a Laserfiche repository. If you are using MSDE (i.e. Laserfiche Server (Team) or Standalone), then it is important that you specify the main SQL database and not one of the expansion databases.

  4. You should see a prompt that looks like the following:

    1>

  5. Type the following and then press ENTER:

    delete from indexqueue

    This step removes all documents currently scheduled to be indexed by the Laserfiche Server.

  6. Type the following and then press ENTER:

    GO

  7. Restart the Laserfiche Server service.
    1. Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    2. Scroll down and select Laserfiche Server 7.x.
    3. From the Action menu, click Restart.