An "Error 1058: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it." Error Occurs When Starting a Service.

March 19, 2007 | KB: 1011778
Laserfiche Server - Team (MSDE) 7, Laserfiche Server - United (MS SQL) 7, Laserfiche Server - United (Oracle) 7, Agenda Manager 7, Workflow Suite 7, Import Agent 7

Summary

When you attempt to start a Laserfiche service, you may receive the following error message:

    Error 1058: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

Cause

The startup type for the service may be set to disabled or the service may be disabled for the current hardware profile.

Resolution

Use Windows Services to modify the startup type or enable the service for the current hardware profile.

To modify service configuration

  1. Click Start and then click Control Panel
  2. Open Administrative Tools.
  3. Open Services.
  4. Scroll down and double-click the appropriate service.
  5. On the General tab, next to the Startup type option, make sure that the service is not disabled. If it is disabled, change the option to Automatic.
  6. On the Log On tab, make sure that the service is enabled for the appropriate hardware profile.