Full Text Search May Silently Fail if the lfword.idx File is Greater than 500 MB.

March 6, 2007 | KB: 1011769
Laserfiche Server - Team (MSDE) 7, Laserfiche Server - United (MS SQL) 7, Laserfiche Server - United (Oracle) 7

Summary

Full text search may fail if the lfword.idx file exceeds 500 MB in size.

Cause

The lfword.idx file has a maximum size limit of around 500 MB. If the file exceeds this size limit, data corruption can occur and text searches may no longer return valid results.

Resolution

There is a hotfix available for Laserfiche Server 7.2.1. The fix is an updated version of LFEng.dll (version 7.2.1.425). The maximum size limit for lfword.idx has been increased to 20 GB.

Important: A previous LFEng.dll hotfix (version 7.2.1.410) contained a fix that required changes to the SQL database table structure. Subsequent versions of LFEng.dll expect the updated table structure. If you are applying a subsequent LFEng.dll hotfix directly on the release version of LFEng.dll (version 7.2.1.407), you must first update the table structure using the SQL scripts provided in Knowledge Base article 1011713.

To update Laserfiche Server 7.2.1

  1. Click the following link to download a zip file containing the updated version of LFEng.dll.
    Hotfix_SCR29425.zip
  2. Stop the Laserfiche Server service.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Select Laserfiche Server 7.2.
    5. From the Action menu, point to All Tasks and select Stop.
  3. Delete the "SEARCH" subfolder located in your repository folder.
  4. Replace your existing version of LFEng.dll located in your Laserfiche Server installation with the updated version contained in the zip file. By default, Laserfiche Server is installed at "C:\Program Files\Laserfiche\Server."
  5. Restart the Laserfiche Server service.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Select Laserfiche Server 7.2.
    5. From the Action menu, point to All Tasks and select Start.
  6. Re-index your repository.
    1. Start the Laserfiche Administration Console.
    2. In the console tree, expand the desired Laserfiche Server item.
    3. Select the desired Laserfiche repository.
    4. Select the Index item listed under the Laserfiche repository.
    5. From the Action menu, point to All Tasks, Index, and then select All Text Documents.

You may receive the following error message in your repository error.log file if you do not first manually delete the SEARCH subfolder:

    [7364] Open repository 'YourRepository' failed: sdbOpenFiles failed. Unable to create files needed in SEARCH directory