Summary
When Laserfiche is installed on a 64-bit edition of Microsoft Windows, you may receive the following error when you attempt to connect to an Oracle database.
[7050] Open repository 'YourRepository' failed: Unable to login as user 'UserName' to oracle service 'Oracle' : ORA-12154: TNS: could not resolve the connect identifier specified.
Cause
This error can occur when the Laserfiche Server installation path contains a parenthesis character. The Oracle driver does not correctly parse program locations that contain parenthesis characters.
Since Laserfiche Server is a 32-bit program, when it is installed on a 64-bit edition of Windows, by default, Laserfiche Server is installed at "C:\Program Files (x86)\Laserfiche\Server."
Workaround
Make sure that the 32-bit Windows Oracle Client is installed. Uninstall Laserfiche Server if it is already installed. Install Laserfiche Server to a location without any parentheses.
More Information
For more information, please reference Oracle Bug 3807408.