Laserfiche Client 6 may Display the Incorrect Page when You Select a Thumbnail.

February 12, 2007 | KB: 1011750
Laserfiche Server - Team (MSDE) 7, Laserfiche Server - United (MS SQL) 7, Laserfiche Server - United (Oracle) 7

Summary

If you are using Laserfiche Client 6 to view a Laserfiche 7 repository, opening a document and clicking on a thumbnail may display the previous image.

Cause

This issue may occur in documents that contain both black/white and color pages. Due to the way the Laserfiche Server reports the next page number, Laserfiche Client 6 may incorrectly read the thumbnail page number.

Resolution

There is a hotfix available for Laserfiche Server 7.2.1. The fix is an updated version of LFEng.dll (version 7.2.1.415).

Important: A previous LFEng.dll hotfix (version 7.2.1.410) contained a fix that required changes to the SQL database table structure. Subsequent versions of LFEng.dll expect the updated table structure. If you are applying a subsequent LFEng.dll hotfix directly on the release version of LFEng.dll (version 7.2.1.407), you must first update the table structure using the SQL scripts provided in Knowledge Base article 1011713.

To update Laserfiche Server 7.2.1

  1. Click the following link to download a zip file containing the updated version of LFEng.dll.
    Hotfix_SCR29031.zip
  2. Stop the Laserfiche Server service.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Select Laserfiche Server 7.2.
    5. From the Action menu, point to All Tasks and select Stop.
  3. Replace your existing version of LFEng.dll located in your Laserfiche Server installation with the updated version contained in the zip file. By default, Laserfiche Server is installed at "C:\Program Files\Laserfiche\Server."
  4. Register LFEng.dll.
    1. Click Start and then click Run
    2. Type the following and then click OK.

      regsvr32 "C:\Program Files\Laserfiche\Server\LFEng.dll"

  5. Restart the Laserfiche Server service.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Select Laserfiche Server 7.2.
    5. From the Action menu, point to All Tasks and select Start.