An "Error 1327. Invalid Drive: DriveLetter" Error Occurs When Installing a Laserfiche Product.

December 22, 2006 | KB: 1011718
Laserfiche 7

Summary

When installing a Laserfiche product, you may receive the following error message:

    Error 1327. Invalid Drive: DriveLetter

Cause

This error can occur if a registry value stored under the following registry keys references the invalid drive letter specified in the error message:

  • HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
  • HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Resolution

Use the Windows Registry Editor to correct any invalid registry values.

Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and then click OK to load the Windows Registry Editor:

    regedt32

  3. Expand HKEY_CURRENT_USER.
  4. Expand Software.
  5. Expand Microsoft.
  6. Expand Windows.
  7. Expand CurrentVersion.
  8. Expand Explorer.
  9. Select Shell Folders.
  10. Verify that all the listed values contain valid paths. If a value contains an invalid drive, double-click the value and modify the data.
  11. Repeat the above step for the other registry keys listed in the above section.

Related Links

For more information, please see the following Microsoft Knowledge Base article:

http://support.microsoft.com/kb/327763