The Laserfiche Server Stops Responding During Thumbnail Generation.

November 13, 2006 | KB: 1011689
Laserfiche 7.1, Laserfiche 7.2

Summary

The Laserfiche Server may stop responding when thumbnails are generated. The issue only occurs when thumbnails are displayed in the document viewer and are generated the first time. If the thumbnail view is disabled, the issue does not occur.

Cause

This issue results from the third-party drivers used to create thumbnails. These drivers occasionally cause issues when generating high-resolution images.

Workaround

This issue can be resolved by reducing the resolution of the images. This can be done in Laserfiche 7.2.1 by modifying your repository's SQL database. Note that this workaround cannot be performed with versions prior to 7.2.1; you must upgrade before performing the workaround.

Important: Reducing the resolution of the images in this fashion may negatively impact thumbnail image quality. It is not necessary or desirable to perform this workaround unless you experience this issue.

To reduce thumbnail image resolution using Enterprise Manager or SQL Server Management Studio Express

  1. Open Enterprise Manager or SQL Server Management Studio Express.
  2. Expand the appropriate SQL Server.
  3. Expand the Databases item.
  4. Expand the database associated with the Laserfiche repository.
  5. Select Tables.
  6. Select the DBOptions table.
  7. Open the table.
    • In Enterprise Manager, from the Action menu, select Open Table, and then select Return All Rows.
    • In SQL Server Management Studio Express, right-click the DBOptions table and select Open Table.
  8. In the last, empty row of the DBOptions table, add a new value. Under OptionName, type "UseLowResThumbnail." Under OptionValue, type "Y."
  9. Restart the Laserfiche Server service.
    1. Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    2. Scroll down and select Laserfiche Server 7.x.
    3. From the Action menu, click Restart.

To reduce thumbnail image resolution using osql

  1. From the Start menu, select Run.
  2. Type the following and then press ENTER:

    cmd

  3. At the command prompt, type the following and then press ENTER:

    osql -E -S SQLInstance -d DatabaseName

    SQLInstance is the name assigned to the desired instance of SQL Server. This term should be replaced by the name of the computer hosting SQL Server. If you are using MSDE (i.e. Laserfiche Server (Team) or Standalone), then you should also append "\Laserfiche" (e.g. Computer\Laserfiche). It is not necessary to append "\Laserfiche" to Microsoft SQL Server 2005 or Microsoft SQL Server 2005 Express.

    DatabaseName is the name of the SQL database associated with a Laserfiche repository. If you are using MSDE (i.e. Laserfiche Server (Team) or Standalone), then it is important that you specify the main SQL database and not one of the expansion databases.
  4. You should see a prompt that looks like this:

    1>

  5. Type the following and then press ENTER:

    INSERT INTO dboptions VALUES ('UseLowResThumbnail','Y')

  6. Type the following and then press ENTER:

    GO

  7. Restart the Laserfiche Server service.
    1. Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    2. Scroll down and select Laserfiche Server 7.x.
    3. From the Action menu, click Restart.

More Information

If you would like to return to using high-resolution thumbnail images, you can do so by removing this value and clearing the thumbnail table. Note that this may cause the server issue to re-occur.

To revert to high-resolution thumbnail images

  1. From the Start menu, select Run.
  2. Type the following and then press ENTER:

    cmd

  3. At the command prompt, type the following and then press ENTER:

    osql -E -S SQLInstance -d DatabaseName

    SQLInstance is the name assigned to the desired instance of SQL Server. This term should be replaced by the name of the computer hosting SQL Server. If you are using MSDE (i.e. Laserfiche Server (Team) or Standalone), then you should also append "\Laserfiche" (e.g. Computer\Laserfiche).

    DatabaseName is the name of the SQL database associated with a Laserfiche repository. If you are using MSDE (i.e. Laserfiche Server (Team) or Standalone), then it is important that you specify the main SQL database and not one of the expansion databases.
  4. You should see a prompt that looks like this:

    1>

  5. Type the following and then press ENTER:

    delete from dboptions where optionname like 'UseLowResThumbnail'

  6. Type the following and then press ENTER:

    GO

  7. Type the following and then press ENTER:

    delete from lft

    This step removes all existing thumbnails from your repository. Laserfiche will automatically re-generate new high-resolution thumbnails when you view documents.

    Note: If you are using MSDE or SQL Server 2005 Express, thumbnail data is stored in the expansion database(s). You must perform this statement on all your DatabaseName_Data_X expansion database(s)

  8. Type the following and then press ENTER:

    GO

  9. Restart the Laserfiche Server service.
    1. Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    2. Scroll down and select Laserfiche Server 7.x.
    3. From the Action menu, click Restart.