Laserfiche Scanning May be Unable to Send OCRed Documents When Laserfiche is Configured to use the Firewall Compatibility Component.

November 3, 2006 | KB: 1011683
Laserfiche 7.2, Scanning 7.2, Web Access 7.2

Summary

Laserfiche Scanning 7.2 may be unable to send documents that have been OCRed when using the Firewall Compatibility Component. If Laserfiche Scanning is in standard scanning mode, you may receive the following error message in the output pane when sending documents:

    Error: Failed to send document DocumentName. Error.

If Laserfiche Scanning is in basic scanning mode, you may receive an empty message box with an OK button.

Cause

Certain performance optimizations included in Laserfiche Scanning 7.2 are incompatible with an FCC environment.

Resolution

If Laserfiche Scanning 7.2.x is communicating with the Laserfiche Server through the Firewall Compatibility Component, modify the registry to disable the incompatible optimizations. This registry setting also requires an updated version of BPConnection72.dll (version 7.2.1.1). This version of BPConnection72.dll is included in Laserfiche Scanning 7.2.1.

To update Laserfiche Scanning

  1. Close any open instances of the Laserfiche client and Laserfiche Scanning.
  2. Click the following link to download a zip file containing BPConnection72.dll and ImportUsing71.reg.
    Hotfix_SCR28109.zip
  3. Extract the contents of the zip file to a temporary location.
  4. If you are using Laserfiche Scanning 7.2, replace the existing version of BPConnection72.dll located at "C:\Program Files\Common Files\Laserfiche\Batch Processor" with the updated version.
  5. Double-click the ImportUsing71.reg file to automatically modify the registry.

Note: This registry setting can be modified through the Laserfiche Scanning Troubleshooter utility included with Laserfiche Scanning 7.2.1.