Summary
When you export an image from a published repository using the Plus Viewer, you may receive the following error message:
There was an error exporting the image "Path to Image". (6000)
Cause
The Laserfiche Viewer Runtime installation included with Laserfiche Plus 7.2 is missing a necessary file (DocumentProcessor72.dll). This installation includes system files needed by the Laserfiche Viewer. When you launch a Plus CD for the first time on a new computer, Plus automatically runs the Viewer Runtime installation and installs these system files. If DocumentProcessor72.dll does not exist on your computer, you will not be able to export documents from your Plus published repository.
There are two methods for resolving this issue:
Note: This issue may not occur if the computer you are using to view the Plus repository has another type of Laserfiche product installed that also installs Document Processor.
Resolution 1
There is an updated Viewer runtime installation package available for Laserfiche Plus 7.2. The updated installation package includes the missing file. The fix also includes an updated version of Launch.exe (version 7.2.0.300). The updated Launch.exe will run the new Viewer runtime installation if it detects that the old version of the Viewer runtime installation is already installed.
To update the Plus 7.2 Viewer runtime installation package
Resolution 2
On computers where you are viewing a published CD created prior to applying Resolution 1, you can manually run the updated Viewer runtime installation.
To update the
Resolution 3
Download and manually copy the needed file to the appropriate location on the viewer computer.
regsvr32 "C:\Program Files\Common Files\Laserfiche\LFObjects\DocumentProcessor72.dll"