A "There was an error exporting the image (6000)" Error Occurs When Using the Plus Viewer to Export a Document From a Published Repository.

April 13, 2007 | KB: 1011470
Plus 7.2

Summary

When you export an image from a published repository using the Plus Viewer, you may receive the following error message:

    There was an error exporting the image "Path to Image". (6000)

Cause

The Laserfiche Viewer Runtime installation included with Laserfiche Plus 7.2 is missing a necessary file (DocumentProcessor72.dll). This installation includes system files needed by the Laserfiche Viewer. When you launch a Plus CD for the first time on a new computer, Plus automatically runs the Viewer Runtime installation and installs these system files. If DocumentProcessor72.dll does not exist on your computer, you will not be able to export documents from your Plus published repository.

There are two methods for resolving this issue:

  • Please see Resolution 1 for information regarding how to resolve this issue on the publishing computer prior to publishing a Plus CD.
  • Please see Resolution 2 or Resolution 3 for information regarding how to resolve this issue on viewing computers attempting to view an existing Plus CD published prior to applying the fix discussed in Resolution 1.

Note: This issue may not occur if the computer you are using to view the Plus repository has another type of Laserfiche product installed that also installs Document Processor.

Resolution 1

There is an updated Viewer runtime installation package available for Laserfiche Plus 7.2. The updated installation package includes the missing file. The fix also includes an updated version of Launch.exe (version 7.2.0.300). The updated Launch.exe will run the new Viewer runtime installation if it detects that the old version of the Viewer runtime installation is already installed.

To update the Plus 7.2 Viewer runtime installation package

  1. Click the following link to download a zip file containing the updated Viewer runtime installation package along with an updated version of Launch.exe (version 7.2.0.300).
    Hotfix_SCR27615.zip
  2. On the computer from which you publish Plus repositories, replace the current version of your Viewer runtime installation package and Launch.exe with the updated versions. By default, the Viewer runtime installation files are located at "C:\Program Files\Laserfiche\client\Plus Runtime Files\Viewer Runtime" and the Launch.exe is located at "C:\Program Files\Laserfiche\Client 7.2\Plus Runtime Files\Viewer."

Resolution 2

On computers where you are viewing a published CD created prior to applying Resolution 1, you can manually run the updated Viewer runtime installation.

To update the

  1. Click the following link to download a zip file containing the updated Viewer runtime installation.
    Hotfix_SCR27615.zip
  2. On the Viewer computer, extract the contents of the zip file to a temporary location.
  3. In the "Viewer Runtime Installation" folder, double-click "Setup.exe" to run the installation

Resolution 3

Download and manually copy the needed file to the appropriate location on the viewer computer.

  1. Click the following link to download a zip file containing DocumentProcessor72.dll.
    DocumentProcessor.zip
  2. Extract DocumentProcessor72.dll to "C:\Program Files\Common Files\Laserfiche\LFObjects."
  3. Register Document Processor.
    1. Click Start and then click Run
    2. Perform one of the following:
    3. Type the following and then click OK to register Document Processor 7.2.

      regsvr32 "C:\Program Files\Common Files\Laserfiche\LFObjects\DocumentProcessor72.dll"