An Uninitialized Internal Object Can Cause Laserfiche Server to Become Unstable.

November 1, 2006 | KB: 1011261
Laserfiche Server - Team (MSDE) 7.1, Laserfiche Server - United (MS SQL) 7.1, Laserfiche Server - United (Oracle) 7.1,Laserfiche Server - Team (MSDE) 7.2.0, Laserfiche Server - United (MS SQL) 7.2.0, Laserfiche Server - United (Oracle) 7.2.0

Summary

The Laserfiche Server may become unstable when it attempts to access an uninitialized connection object. When this occurs, the Laserfiche Server may stop and restart itself.

Cause

In certain situations, an internal connection object may not be properly initialized. The Laserfiche Server was not properly verifying that this internal object first existed before attempting to access this object. Attempting to access this NULL object could cause the Laserfiche Server to become unstable.

Resolution 1

This issue is resolved in Laserfiche Server 7.2.1. Please upgrade to the latest version of Laserfiche Server.

Resolution 2

There is a hotfix available for Laserfiche Server 7.2. The fix is an updated version of LFEng.dll (version 7.2.0.320).

To update Laserfiche Server 7.2

  1. Stop the Laserfiche Server service.
    1. Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    2. Scroll down and select Laserfiche Server 7.2.
    3. From the Action menu, click Stop.
  2. Click the following link to download a zip file containing LFEng.dll (version 7.2.0.320).
    Hotfix_SCR27034.zip
  3. Replace the existing version of LFEng.dll located in your Laserfiche Server installation folder with the version included in the zip file. By default, the Laserfiche Server is installed at C:\Program Files\Laserfiche\Server.
  4. Restart the Laserfiche Server service.
    1. Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    2. Scroll down and select Laserfiche Server 7.2.
    3. From the Action menu, click Start.