Summary
Workflow may be unable to route documents if the routing criteria reference a template field that is populated using the $PARENT$ or $PARENT:FIELD$ token.
Cause
When the $PARENT$ or $PARENT:FIELD$ token is set on a document, the Laserfiche Server erroneously stores the token itself rather than the value which the token references. Workflow is therefore unable to route based on that value. The document's template field value itself is not affected.
Resolution 1
This issue is resolved in Laserfiche Server 7.2.1. Please upgrade to the latest version of Laserfiche Server.
Resolution 2
There is a hotfix available for this issue. The fix includes an updated version of LFEng.dll (version 7.2.0.310).
To update Laserfiche Server 7.2
More Information
For another issue with the same root cause and resolution, please see the following Laserfiche Knowledge Base article:
1011228 FIX: A Document's Template Field Value is Reported As "$PARENT$" in Audit Trail.