Documents Whose Template Fields Contain the $PARENT$ Token May Not Be Routed By Workflow

November 1, 2006 | KB: 1011227
Workflow Suite 7, Laserfiche Server - Team (MSDE) 7.2, Laserfiche Server - United (MS SQL) 7.2, Laserfiche Server - United (Oracle) 7.2

Summary

Workflow may be unable to route documents if the routing criteria reference a template field that is populated using the $PARENT$ or $PARENT:FIELD$ token.

Cause

When the $PARENT$ or $PARENT:FIELD$ token is set on a document, the Laserfiche Server erroneously stores the token itself rather than the value which the token references. Workflow is therefore unable to route based on that value. The document's template field value itself is not affected.

Resolution 1

This issue is resolved in Laserfiche Server 7.2.1. Please upgrade to the latest version of Laserfiche Server.

Resolution 2

There is a hotfix available for this issue. The fix includes an updated version of LFEng.dll (version 7.2.0.310).

To update Laserfiche Server 7.2

  1. Stop the Laserfiche Server service.
    1. Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    2. Scroll down and select Laserfiche Server 7.2.
    3. From the Action menu, click Stop.
  2. Click the following link to download a zip file containing the hotfix.
    Hotfix_SCR26718.zip
  3. Replace the existing version of LFEng.dll located in your Laserfiche Server installation folder with the version included in the zip file. By default, the Laserfiche Server is installed at C:\Program Files\Laserfiche\Server.
  4. Restart the Laserfiche Server service.
    1. Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    2. Scroll down and select Laserfiche Server 7.x.
    3. From the Action menu, click Start.

More Information

For another issue with the same root cause and resolution, please see the following Laserfiche Knowledge Base article:

1011228 FIX: A Document's Template Field Value is Reported As "$PARENT$" in Audit Trail.