Template Matching Behavior May Be Unexpectedly Broad when Attaching a Volume.

May 12, 2006 | KB: 1011189
Laserfiche Server - Team (MSDE) 7, Laserfiche Server - United (MS SQL) 7, Laserfiche Server - United (Oracle) 7

Summary

When you attach a volume, documents with a template not in the repository may be assigned to an existing template that has the same field names.

Cause

When you attach a volume, Laserfiche attempts to match templates in the new volume with any templates already existing in the repository. The matching algorithm does not explicitly only match against existing templates that have the same name. The algorithm will also compare the field names. If it finds a pre-existing template with a different name that has the same field names, it will consider that a match and assign the documents to that pre-existing template.

Workaround

Recreate the desired template in your repository before attaching the volume.