Summary
When you are logged in to Windows as a non-domain account and try to send a document to Laserfiche, any field values you set will not be saved.
Cause
There is an issue with select functions in the client API involving DCOM.
Resolution 1
This issue is resolved in Laserfiche 7.2. Please upgrade to the latest version of Laserfiche.
Resolution 2
There is a hotfix available for Laserfiche 7.1.x. The fix is included in LFSO71.dll (version 7.1.0.285 and later).
To update Laserfiche client 7.1.x
regsvr32 "C:\Program Files\Common Files\Laserfiche\LFObjects\LFSO71.dll"