An Approver that has Been Removed From an Approval Stage May Still Receive Approval Reminder Notification E-mail Messages.

April 7, 2006 | KB: 1011161
Agenda Manager 7.1

Summary

When removing approvers from multiple stages in an approval route, it is possible that an approver who is removed from a later stage may incorrectly receive an additional set of approval reminder e-mail notifications.

Cause

If an item is waiting for approval from one last approver in an approval stage and that approver is removed from the stage, that item is automatically routed to the next approval stage and the appropriate e-mail notifications are sent. The issue arises if you also remove an approver from this next stage. When removing approvers from multiple stages, Agenda Manager starts at the beginning of the approval route and moves from stage to stage applying your changes. This can lead to a situation where the last approver for an item is removed from a stage, the item is routed to the next stage, and e-mail notifications are sent out, all before your change of removing the approver from the next stage has been saved.

Resolution 1

This issue is resolved in Laserfiche Agenda Manager 7.2. Please upgrade to the latest version of Agenda Manager.

Resolution 2

There is a hotfix available for Agenda Manager 7.1. The fix is an updated version of AMServer.exe (last modified on April 5, 2006). Agenda Manager now starts from the last stage and works backwards when saving changes to an approval route.

To update Agenda Manager 7.1

  1. Stop the Agenda Manager Server.
    1. Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    2. Scroll down and select Laserfiche Agenda Manager Service.
    3. From the Action menu, click Stop.
  2. Click the following link to download a zip file containing the updated version of AMServer.exe.
    Hotfix_SCR25450.zip
  3. Replace the existing AMServer.exe located in the Agenda Manager Server installation folder with the updated version. By default, Agenda Manager Server is installed at C:\Program Files\Laserfiche\Agenda Manager Server.
  4. Restart the Agenda Manager Server.
      Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    1. Scroll down and select Laserfiche Agenda Manager Service.
    2. From the Action menu, click Start.