Summary
When accessing the Web Access website, users are prompted to download ActiveX controls to enable certain features. For some users on Windows 2000, attempting to download these controls may cause Internet Explorer to crash.
Cause
Web Access uses ActiveX controls to implement thumbnail management and (in Web Access 7.1 and higher) scanning. The first time a Web Access website is visited on a particular computer, the user will be prompted to download the controls. However, due to an issue in Internet Explorer, attempting to install these controls when using the Windows 2000 operating system can cause the browser to crash.
As the issue originates in a file in Internet Explorer, Laserfiche is unable to resolve the problem. Laserfiche currently has a pending support request with Microsoft, but as Windows 2000 is no longer under warranty support, no resolution appears to be imminent. Unless the issue with Internet Explorer is resolved by Microsoft, Laserfiche will not support those Web Access features which require ActiveX controls on Windows 2000 computers. Those features include dragging and dropping of thumbnails and web scanning.
This does not apply to accessing Web Access on Windows XP or Windows Server 2003, which are fully supported. However, if you encounter these problems while using Windows XP or Windows Server 2003, it may be necessary to update your Internet Explorer installation to the most recent version. For more information on updating Internet Explorer, see the following Microsoft web page:
Resolution
Upgrade affected computers to Windows XP or Windows Server 2003, and update Internet Explorer to the most recent version.
Workaround
The ActiveX control can be disabled such that Internet Explorer will not attempt to install the control and the issue will not occur. This will disable the ability to drag and drop thumbnails or scan for all users.
To disable the ActiveX thumbnail control
Const ACTIVEX_THUMBNAIL_DISPLAY = True
Const ACTIVEX_THUMBNAIL_DISPLAY = False