A "The LaserFiche Client could not be opened." Error Occurs When Laserfiche Client 7 is Loading.

July 5, 2006 | KB: 1011132
Integration Express 6, Integrator's Toolkit 6

Summary

When using Integration Express 6 or a custom program built using the Integrator's Toolkit 6 to load Laserfiche client 7, you may receive the following error message:

    The LaserFiche Client could not be opened. Please make sure it is installed and is working properly

Cause

Laserfiche Image Enable (version 6.0.0.x) times out too quickly when waiting for Laserfiche client 7 to load the DDE connection.

Resolution

There is a hotfix for Integration Express 6 and Integrator's Toolkit 6. The fix is an updated version of LFImageEnable.dll (version 6.0.0.3). Image Enable now has an increased timeout limit when waiting for Laserfiche client 7 to load.

To update Image Enable

  1. Click the following link to download a zip file containing an updated version of LFImageEnable.dll (version 6.0.0.3).
    Hotfix_SCR24980.zip
  2. Replace the existing version of LFImageEnable located in C:\Program Files\Common Files\Laserfiche\LFAPI with the version included in the zip file.
  3. Register the new version of LFImageEnable.dll.
    1. Click Start and then click Run.
    2. In the Run dialog box, type the following and click OK to register the file:

      regsvr32 "C:\Program Files\Common Files\Laserfiche\LFAPI\LFImageEnable.dll"

More Information

Please see the following Knowledge Base article for information regarding an issue with a different underlying cause that displays the same error message.

1011216 A "The LaserFiche Client could not be opened." Error Occurs When Laserfiche Client 7 is Loading.