Laserfiche Server 7 Becomes Unresponsive for Laserfiche Client 6 Instances.

June 26, 2006 | KB: 1011127
Laserfiche Server - Team (MSDE) 7, Laserfiche Server - United (MS SQL) 7, Laserfiche Server - United (Oracle) 7

Summary

In certain situations, Laserfiche Server 7 can block all calls made using the legacy LFAPI client interface. When this blocking issue occurs, all Laserfiche client 6 instances will hang. Client applications that do not use the legacy client interface, such as Laserfiche client 7, are unaffected.

Cause

This issue can occur if an instance of Laserfiche client 6 is forcibly closed while in the middle of performing a task. When this occurs, the Laserfiche Server will attempt to log out that connection. However, the server will not finish the logout process until it first finishes processing the client's original request. While the server waits to complete the logout process, it will block all LFAPI requests, thus freezing any client applications that use the LFAPI legacy interface. For example, if a Laserfiche client 6 instance is forcibly closed while performing a time-intensive task, such as performing a fuzzy search, the Laserfiche Server will block all other Laserfiche client 6 instances until that fuzzy search finishes and the Laserfiche Server can finish logging out that connection.

Resolution 1

This issue is resolved in Laserfiche Server 7.2. Please upgrade to the latest version of Laserfiche Server.

Resolution 2

There is a hotfix available for Laserfiche Server 7.1.2. The fix is an updated version of LFS.exe. The fix is included in LFS.exe version 7.1.2.620 and later.

To update Laserfiche Server 7.1.2

  1. Stop the Laserfiche Server.
    1. Click Start and click Control Panel.
    2. Open Administrative Tools.
    3. Open Services.
    4. Scroll down and select Laserfiche Server 7.x.
    5. From the Action menu, point to All Tasks, and click Stop.
  2. Click the following link to download a zip file containing LFS.exe (version 7.1.2.620).
    Hotfix_SCR17232.zip
  3. Replace the LFS.exe located in your Laserfiche Server installation folder with the one included in the zip file. By default, Laserfiche Server is installed at C:\Program Files\Laserfiche\Server.
  4. Restart the Laserfiche Server.
    1. Click Start and click Control Panel.
    2. Open Administrative Tools.
    3. Open Services.
    4. Scroll down and select Laserfiche Server 7.x.
    5. From the Action menu, point to All Tasks, and click Start.