A "Server Application Unavailable" Error Occurs When Accessing WebLink.

February 20, 2006 | KB: 1011126
WebLink 7

Summary

When trying to access the WebLink site, you may receive one of the following error messages:

  • Server Application Unavailable
  • Server cannot access application directory 'C:\Program Files\Laserfiche\WebLink 7\Web Files\'. The directory does not exist or is not accessible because of security settings.

The Event Viewer may contain errors involving the ASP.NET process identity not having sufficient permissions.

Cause

In IIS 5, ASP.NET web application code runs in a worker process using a local machine account named ASPNET. The ASPNET account must be able to read the Web Files subfolder of your WebLink 7 installation folder.

Resolution

Grant the ASPNET local machine account read access to the Web Files subfolder located in your WebLink 7 installation folder.

To change the security for the Web Files folder

  1. Using Windows Explorer, browse to the WebLink 7 installation folder.
  2. Select the Web Files subfolder.
  3. From the File menu, click Properties.
  4. Click the Security tab.
  5. Add the ASPNET local machine account and allow Read.
  6. Click OK to save your changes and close the dialog box.

Related Links

For information on the Windows permissions needed by standard user accounts logging in to WebLink, please see the following Knowledge Base article:

1000943 : Minimum Set of Windows Permissions Needed to Use WebLink.