Indexing Documents Written in a Multi-byte Language Can Potentially Crash Laserfiche.

February 13, 2006 | KB: 1011116
Laserfiche Server - Team (MSDE) 7, Laserfiche Server - United (MS SQL) 7, Laserfiche Server - United (Oracle) 7

Summary

Indexing documents written in a multi-byte language (e.g. Chinese) can potentially crash the Laserfiche Server.

Cause

If the Laserfiche Server computer's code page is set to the multi-byte language, the indexing process would destabilize Laserfiche Server. The Laserfiche Server will remain unstable until the problem document is manually removed from the indexing queue.

Resolution 1

This issue is resolved in Laserfiche 7.2. Please upgrade to the latest version of Laserfiche.

Note: The hotfix for 7.1.2 was incorporated into Laserfiche 7.2. This means that Laserfiche will not crash in such a situation. Laserfiche does not support performing searches on documents in multi-byte languages.

Resolution 2

There is a hotfix available for Laserfiche Server 7.1.2. The fix is an updated version of LFEng.dll. The fix is included in LFEng.dll version 7.1.2.610 and later.

Note: This hotfix prevents Laserfiche Server from crashing in such a situation. It does not add support for performing searches on documents in multi-byte languages.

To update Laserfiche Server 7.1.2

  1. Stop the Laserfiche Server.
    1. Click Start and click Control Panel.
    2. Open Administrative Tools.
    3. Open Services.
    4. Scroll down and select Laserfiche Server 7.x.
    5. From the Action menu, point to All Tasks, and click Stop.
  2. Click the following link to download a zip file containing LFEng.dll (version 7.1.2.610).
    Hotfix_SCR24677_24698.zip
  3. Replace the LFEng.dll located in your Laserfiche Server installation folder with the one included in the zip file. By default, Laserfiche Server is installed at C:\Program Files\Laserfiche\Server .
  4. Restart the Laserfiche Server.
    1. Click Start and click Control Panel.
    2. Open Administrative Tools.
    3. Open Services.
    4. Scroll down and select Laserfiche Server 7.x.
    5. From the Action menu, point to All Tasks, and click Start.

More Information

For information on a different issue that was also fixed in LFEng.dll (version 7.1.2.610), please see the following Knowledge Base article:

1011113 Adding a Page to a Document While that Document is Being Indexed Can Potentially Crash Laserfiche.