An "Error 7390 (Object Locked)" Error Occurs When Migrating a Document from the Search Results.

February 13, 2006 | KB: 1011110
Laserfiche Server - Team (MSDE) 7, Laserfiche Server - United (MS SQL) 7, Laserfiche Server - United (Oracle) 7

Summary

When you attempt to migrate a document listed in the search results, you may receive the following error message

    Error 7390 (Object Locked)

Cause

This issue only occurs when you perform a text search and the Show context lines option is enabled for the search results. Laserfiche Server incorrectly places an additional lock on a document when displaying context highlights in the search results window.

Workaround

Disable the Show context lines option if you want to migrate documents from the search results window after performing a text search.

To disable the Show context lines option

  1. From the Tools menu, click Options.
  2. In the Options dialog box, double-click Search.
  3. In the Search Options dialog box, in the Search result display section, clear the Show context lines option.
  4. Click OK to save your change and close the Search Options dialog box.