Errors Occur When Sending Files With Long File Names to Laserfiche from Windows Explorer

February 2, 2006 | KB: 1011094
Laserfiche 7

Summary

When using the "Send To Laserfiche" option from within Windows Explorer on files with very long file names, you may receive the following error one or more times:

    Send to Laserfiche does not support importing folders at this time. You will have to select the files in the folder and send them to Laserfiche.

This only occurs if the complete file name (including extension) is 255 or 256 characters long. An empty Laserfiche document will be created, and the file itself will not be imported.

Cause

This is an issue with the Windows "Send To" functionality. When Windows uses "Send To" to handle files with very long file names, a portion of the file name may be truncated. For files of 255 or 256 characters, the extension is truncated. This results in the file being treated as one or more folders. This issue is not restricted to the "Send To Laserfiche" function; it can be seen with some other, non-Laserfiche Send To commands as well.

Resolution

This issue is resolved in Laserfiche 7.2. Please upgrade to the latest version of Laserfiche.

Workaround

This error does not occur when importing a file from within the Laserfiche client. It also does not occur with files whose file names contain 254 or fewer characters. To avoid this issue, either shorten the name of the file or import the file through the Laserfiche client.