Cannot Scan a Sample Image With Kofax.

November 1, 2006 | KB: 1011067
Quick Fields 7

Summary

When you attempt to scan a sample image using Kofax, you may receive the following error message:

    error: failed to scan sample image

In certain situations, you may not receive the previous error message. The scanner will scan the sample page and the temporary copy of the sample image is created on the file system. However, the sample image does not appear in Quick Fields.

Cause

There was an issue with the Laserfiche interface with Kofax.

Resolution 1

This issue is resolved in Quick Fields 7.1.2 and later. Please upgrade to the latest version of Laserfiche Quick Fields.

Resolution 2

There is a hotfix available for Laserfiche Quick Fields 7.1.1. The fix is an updated version of LFKofaxCom.dll.

To update Quick Fields 7.1.1

  1. Click the following link to download a zip file containing LFKofaxCom.dll.
    Hotfix_SCR22179.zip
  2. Replace the existing LFKofaxCom.dll at C:\Program Files\Common Files\Laserfiche\Batch Processor\LFKofaxCom with the version in the zip file.
  3. Register the new dll.
    1. Click Start and then click Run
    2. Type the following and then click OK to register the dll.

      regsvr32 "C:\Program Files\Common Files\Laserfiche\Batch Processor\LFKofaxCom\LFKofaxCom.dll"

Workaround 1

Use VCDemo to first scan the sample page. Then, import the image as the sample image through Quick Fields.

Workaround 2

The scanner may scan the sample page, but the image does not appear in Quick Fields. A temporary copy of the image is still saved to your Windows user's temporary folder. In Quick Fields, choose to import a sample image. Browse to your Windows user's temporary folder and select the latest BPX*.tmp file. By default, your Windows user's temporary folder is located at C:\Documents and Settings\UserName\Local Settings\Temp.

To check your Windows user's temporary folder environment variable

  1. Click Start and then click Control Panel.
  2. Double-click System.
  3. Click the Advanced tab.
  4. Click Environment Variables.
  5. In the User variables for UserName section, check the value specified for the TEMP variable.