A "Could not create volume. [7112]" Error Occurs When Attaching a Volume.

December 16, 2005 | KB: 1011066
Server (MSDE) 7, Server (MSSQL) 7, Server (Oracle) 7

Summary

You may receive the following error when trying to attach a volume:

    Could not create volume. [7112]

The following error message will be displayed in the repository's error.log:

    [7112.7050] Volume import failed: Could not create volume entry.

Cause

The volume attach process is dependent on the DBMS service. If the DBMS service is stopped and restarted, but the Laserfiche Server service is not also restarted, the volume attach process will fail. You must also restart the Laserfiche Server after restarting the DBMS.

Resolution

When the DBMS is restarted, the Laserfiche Server service should also be restarted. This will renew any failed threads or processes. Ideally, the frequency with which the DBMS is restarted should be minimized. If you are using a backup solution that necessitates stopping or restarting the SQL server frequently, you may need to investigate other backup solutions.

More Information

For more information regarding restarting the DBMS server, please see the following Knowledge Base article:

1011062 INFO: The Laserfiche Server Must Be Restarted when the DBMS is Restarted