The Laserfiche Server Must Be Restarted when the DBMS is Restarted.

December 7, 2005 | KB: 1011062
Server (MSDE) 7, Server (MSSQL) 7, Server (Oracle) 7

Summary

When the DBMS associated with a Laserfiche repository is restarted, the Laserfiche Server must be restarted. If the DBMS is restarted but the Laserfiche server is not, users may encounter issues while using Laserfiche. These issues include indexing problems, search anomalies, workflow and auditing synchronization problems, and errors when attempting to import a briefcase or attach a volume.

Cause

Certain processes in Laserfiche are dependent on the DBMS service. If the DBMS service is stopped, these processes may fail.

Resolution

After the DBMS has been restarted, the Laserfiche Server should also be restarted. This will renew any failed threads or processes. Ideally, the frequency with which the DBMS is restarted should be minimized. If you are using a backup solution that necessitates stopping or restarting the DBMS frequently, you may need to investigate other backup solutions.

More Information

For more information regarding restarting the DBMS, please see the following Knowledge Base article:

1011061 ISSUE: Indexing Silently Fails When the DBMS Is Restarted And The Laserfiche Server is Not Restarted.

1011064 ERROR: A "Attaching volume failed. [7522]" Error Occurs When Importing a Briefcase

1011066 ERROR: A "Could not create volume. [7112]" Error Occurs When Attaching a Volume