Indexing Silently Fails When the DBMS Is Restarted And The Laserfiche Server Is Not Restarted.

December 7, 2005 | KB: 1011061
Server (MSDE) 7, Server (MSSQL) 7, Server (Oracle) 7

Summary

Indexing may fail if the DBMS is restarted and the Laserfiche Server is not restarted. No error message will be displayed or logged, but searches may be out of date, search results may not appear correctly, and documents will not be successfully indexed.

Cause

The Laserfiche indexing thread is dependent on the DBMS service. If the DBMS service is stopped, the indexing thread will be unable to operate and will fail. Once the thread has failed, only restarting the Laserfiche Server can start it again.

Resolution

When the DBMS is restarted, the Laserfiche Server service should also be restarted. This will renew any failed threads or processes. Ideally, the frequency with which the DBMS is restarted should be minimized. If you are using a backup solution that necessitates stopping or restarting the DBMS frequently, you may need to investigate other backup solutions.

More Information

For more information regarding restarting the DBMS server, please see the following Knowledge Base article:

1011062 INFO: The Laserfiche Server Must Be Restarted when the DBMS is Restarted